Scheduled for 10, June, 2025 at 2:00 PM – 4:45 PM
Affects
Mindstate Learning
Under maintenance from 2:00 PM to 4:45 PM
Completed
10, June, 2025 at 4:45 PMCompleted
10, June, 2025 at 4:45 PMMaintenance has completed successfully.
In progress
10, June, 2025 at 2:00 PMIn progress
10, June, 2025 at 2:00 PMMaintenance is now in progress
Planned
10, June, 2025 at 2:00 PMPlanned
10, June, 2025 at 2:00 PMWe are planning for a scheduled maintenance to upgrade the website to a new service.